[WordPress] Du hast nicht ausreichend Rechte, um auf diese Seite zuzugreifen. – Updater

WordPress-LogoIn einer von mir betreuten WP-Installation hatte ich das Problem das der Updater nicht verfügbar war im Menu.
Bei einem Klick auf die Update-Meldung landete ich auf einer Fehlerseite mit dem Text Du hast nicht ausreichend Rechte, um auf diese Seite zuzugreifen.
Selbiges Verhalten auch beim automatischen installieren von Plugins.

Die Suche bei den üblichen Anlaufstellen (WordPress-Deutschland und Google) brachten mich nicht sonderlich weiter, und auch ein komplettes Löschen der Dateien mit anschliessendem neu hochladen brachte keine Lösung.

Letzendlich bin ich doch auf eine Lösung im Forum von wordpress.org gestossen.
In der Datenbanktabelle _options den Eintrag db_version auf 8204 gesetzt, im Blog neu angemeltet und das darauffolgende Datenbankupgrade durchgeführt.
Danach war die Welt in Ordnung und ich konnte das Update auf WordPress 2.8.1 mittels Autoupdater durchführen.
Aber Achtung:
Die db_version muss wirklich auf 8204 gesetzt werden. Ich hatte zuerst einfach einmal 10000 genommen, es musste auch ein Upgrade gemacht werden, aber schaffte keine Abhilfe.

[Topic @WordPress-Support]




Trackback-Url Trackback

2 Kommentare für “[WordPress] Du hast nicht ausreichend Rechte, um auf diese Seite zuzugreifen. – Updater”

  1. www.gravatar.com
  2. www.gravatar.com
blog stats